Start a new topic

Smart Pedometer memory is very low

My Smart Pedometer is showing a message saying program memory is very low. I tried using the sync program (on a Mac) to repair the device, but it won't sync (device is never detected).

I uninstalled the sync program and reinstalled, but that didn't help.  I also rebooted my Mac after the reinstall, but that also didn't help.

Any suggestions?  The Pedometer won't let me do anything else.

1 Comment

My pedometer is working again, thanks to Striiv support's help.  I lost all my data on the device, but at least it is working!

I had turned off my pedometer (holding the power button for 20 seconds) because the screen saver wasn't working while displaying the program memory low message.  When I tried to reboot the pedometer (a single press of the power button), it go to the "let's do this" screen but then showed the Striiv logo, and

went back to "let's do this".  And repeated, over and over and over.

I tried going into the striiv sync app "Repair Striiv Device" from the main menu, then connecting the

device, with no luck. It looked like the pedometer was never detected.

Based on Sarah's help from Striiv support, I then tried the same thing, but connected my pedometer

differently.  I powered it down, attached it to my computer, opened up the sync app and went to 

the "Repair Striiv Device" menu.  When it prompted me to connect the device, I powered it on.

It downloaded a new version, but I still couldn't get it to boot. (Again, it got stuck in a loop after

"let's do this").

After about a day, I tried the same steps again.  This time, I got a message from the Sync app saying

"Common_NoAlpha.apg" couldn't be copied to "App" (or something close to that).  The pedometer

looked like it was powered off again.

When I restarted it (hitting the power button once), the pedometer showed an unhappy face and a message to the effect of "Striiv is out of sorts".  The sync app said that the device needs repairs and warned that it might take a few minutes.  At about the same time, the pedometer showed "learning new stuff".   Another sync completed... and the pedometer powered up.  It started from scratch, prompting me for my name and other info, and all data appears to be lost, but it is working again, which is good news.

Login or Signup to post a comment